I recently hired into a data analytics team for a hospital, and we don’t have a style guide. Lots of frustration from folks working with legacy code…I thought putting together a style guide would help folks working with code they didn’t write, starting with requiring a header for SQL scripts first as low hanging fruit.

Or so I thought.

My counterpart over application development says that we shouldnt be documenting any metadata in-line, and he’d rather implement “docfx” if we want to improve code metadata and documentation. I’m terrified of half-implementing yet another application to further muddy the waters–i’m concerned it will become just one-more place to look while troubleshooting something.

Am I going crazy? I thought code headers were an industry standard, and in-line comments are regarded as practically necessary when working with a larger team…

  • …what the code does, not why it does it

    This is my issue with “it’s self documenting code!”. I’m a maintenance coder. I deal with people’s code long after they’re dead (or ragequit). Some are for control systems.

    if (waterPressure_psi > 500) raise PipeMayBurstException. Okay, we’re dealing with water pressure, in psi unit, and if it’s too high, it may break the piping. Self documenting!!

    Except that our pipes are rated for 1000psi. SO WHY THE 500?! Do we have one or two sites - out of hundreds - with lower rated pipes? I can double performance if we raise the threshold to 700, well within the safety tolerance, but AM I GONNA KILL SOMEONE when they upgrade to our latest controller??

    • Ugh, a Magic String (I call it that whatever the type)

      FACILITY_MAX_PRESSURES = {
          "Durham": 1000,
          "Ipswich": 500,
          "Calne": 750,
      }
      
      max_pressure = list(sorted(
          FACILITY_MAX_PRESSURES.values()
      ))[-1]
      
      if water_pressure > max_pressure:
          blah
      

      Obviously it should really pull from facility management, but that’s a bunch of moving parts where a constant is how you’d prefer the code to work

      Tbh it starts to look better to just define a constant and comment it.